HOME DOCUMENTATION DOWNLOADS BLOG

Not displaying "č" at the end of words in pdf generated from FastReport

Environment:

user environment

Object:

PDF document generated

Initial conditions:

  • I have created a FastReport scheme .frx
  • There are different words using “č” – for example “Kč” or “čištění” (the preview in FastReport looks good, I am using Ubuntu font)

Steps to reproduce:

I open the PDF document in User Environment

Expected result:

All letters “č” will be visible in the pdf document.

Current result:

On places, where letter “č” is situated at the end of a word, it is not displayed in the pdf document.

If you put more letters would it display? Is it really just “č” specifically?

Does it display well in FastReport designer preview?
Can you try displaying it using Architect? (Go to the menu model -> right click on the menu -> Execute and navigate through the desktop GUI).

When I write “Kč” it does not display “č” in the pdf
When I writhe “Kč ř” it does display “Kč ř” in the pdf.
When I write “Kč čč” it does display just “K” in the pdf.

In all cases it is displayed correctly in the FastReport preview.
I tried it with all this letters at the end of a word “ěščřžýáíéúů” and only “č” is not working properly, any other words look ok, so far as I could see.
I do not know, how to display the button “Vytvoř plachtu” in the desktop GUI in the Architect (i see the Menu, but the button is not displayed), so I could not test this situation.
image

The button should be in the toolbar on the top of the screen. Desktop does not support the button placement inside the screen section. If not there, just switch it to “Toolbar” then it should definitely show up in the Architect’s toolbar.

I see, thanks for the guiding. I found the button, but when I press it and wanted to save the document, I am not able to choose any suffix. If I press SAVE, than an error appears - “Value cannot be null. Parameter name: type”.

What shall I do now? I am not able to download the report using Architect, so I can not tell if the letter “č” is displayed correctly or not.

Please try the latest server master build. It has an upgraded FastReports engine.

The update to the latest master version 7145 did not helped (nor in the user interface nor in the Architect).
What more, now when I am Dicconnecting the Model in Architect, an error occurs.
obrazek

I updated Architect (via Setup_Master_Setup_master_7145_artifacts), updated Docker as well, but still no “č” at the end of somer words.
Another czech letters are displayed.

In FastReport preview all letters are visible, in user interface of Origam (pdf document) not. I am not able to display the preview in Architect.

Comparison of previes in FastReprot and Origam UserInterface.