origam.com

Displaying generated PDF report ends with `TypeError: t is null`

Version:

master-latest, html5
2021.2.0.2337

I was trying to …

  1. Print report in FastRepots and display PDF on a screen

I was expecting …

  1. Report will be displayed

Instead I’ve got …

  1. PDF is shown for a moment and then the error is displayed and generated PDF disappear.

Notes

You might know about this issue but in case you don’t know I rather write it here. If it would work, I might use newer Origam version for development.

There is visible error in Console:

1 Like

Which browser do you use?

I use Mozilla Firefox for development.

Can you confirm that you actually get 2 http requests for the report? The report can only be requested once with the provided URL. So for the second time it returns nothing.

No, I can’t confirm. It looks like that report is called only once (3rd row):

@washi isn’t it possibly related to this topic? Error when report action returns a PDF - #2 by jsusen

It looks like a different problem.

We do not know about this issue. Can you please test it with the latest build? If it is still broken we will have a look at it.

Hi Tomáš,

yes, the issue is still there (version 2021.2.0.2345):

obrazek

Thank you,
David

I have tested on last version and worked properly. A version is 2021.2.0.2346

I experience still the same error :man_shrugging:

obrazek

obrazek

I currently use for the development version 2190 which works fine.

I have tested it again and it looks like the problem specifically in Mozilla Firefox (I have version 94.0.2). In Google Chrome on our dev/test environments the solution works fine. (I also have tried CRTL+F5 but it doesn’t help).

MS Edge works as well.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.