Number formatting (currency)

I have a field of Currency type, it is used for calculated amount. I need to show it in two decimals (123,40).
If there are more decimals saved (e.g. after multipliing), all of them are shown in GUI now.

I tried to use CustomNumberFormat property with #,## but it doesn’t work.
What mask should I use?
Or what else can I do?

CustomNumberFormat property is functional in the current master build. It’s still in testing phase. To get desired result you need to enter #.00.

With a dot or with a comma? I would expect that a decimal point would be written as a dot. No matter if the current locale settings are set that it is actually a comma. The way it is written should not be dependent on the locale.

With a dot. I made a mistake.

@Kit4it did it work? Is this question solved?

As far as I have tested, it works well - you have to have very new master version.
But finally I used another approach - I’m rounding it in a rule by this way:
round(AS:Mul(@AmountInvoiceCurrency,@Rate) * 100) div 100
I think it is safer to let to round server, than Flash.
(Once more thanks for this advice, Peter :slight_smile: )

1 Like