API - data page - how to omit @ in attribute names in JSON

When I setup API data page in a way that it omits ROOT element, I get a result where all attribute names have @ as a first character, e.g. @AttributeName1”.

Resulting JSON is in my eyes not clean. I would like to omit the @ character.

Any idea how to do it?

Does it mean if you just turn the option to omit Root element off you get attributes without @?

Nope. It means I setup OmitJsonRootElement to true and fill in Transformation so that everything is copied 1:1 and then the root element is omitted.

But all attributes have @ as a first character anyway.

My solution to that was to switch XMLMappingType for every field in api DataStructure to Element. Than all @ characters disappeared.

Can you please make a screenshot of your API model element so it is clear what combination are you using?

This setting causes ROOT element to be omitted from JSON result.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.