Disable interactive logging for e2e tests

Until now e2e test logs have been bloated by Jest running in interactive mode although it is being executed in CI (continuous integration) environment. When run on command line locally there is supposed to be a text rewritten each second which happens to write down several log lines on CI with this period.

CI mode shall be activated automatically by default (determined by environment variable CI=true), but it does not happen for us because we run them in nested docker-compose, which does not pass the CI setup to its managed containers.

This is fixed by adding CI=true to docker compose environment settings.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.