origam.com

Origam Architect - Create new project with PostgresSQL database fail on missing System.Numeric.Vectors.dll

I was trying to …

  1. Create new project with database PostgresSQL using New Project wizard.

I was expecting …

The new project would be created.

Instead I’ve got …

Exception of missing dll library System.Numerics.Vectors.dll

Further examinations

  1. I have tried to compile architect from current source code. I ran Origam Architect and I was able to create new project.
  2. I have tried to copy all dlls from Debug folder to Origam Architect installation.
  3. I ran the New Project wizard again and I was able to successfully create project (using project template of version 2022.1.0) - 2022.2.0 ended up with an error creating User that the column IsLockedOut is missing - that would be probably different versions of model and Architect.

Suggestions

Compile Origam Architect to include proper dlls and distribute it to support PostgresSQL with no troubles.

I can try to fix it but I would need some information how to use WIX to create OrigamSetup.msi file to test it locally before commit. I see that OrigamSetup.wsx does not contain reference to System.Numerics.Vectors.

I need to solve this issue because it complicates sharing the model with my collegues as I need development on PostgreSQL database.

You are right that you need to add it to OrigamSetup.wsx among the other dependencies. Each dependency has a component and a feature so you need to add it in two places.

Example of a component (you need to generate a unique Guid):

<Component Id="ORIGAM.SECURITY.COMMON.DLL" DiskId="1" 
   Guid="453d8088-1083-4aca-8c8c-397d9dfccc76">
   <File 
        Id="ORIGAM.SECURITY.COMMON.DLL" 
        Name="Origam.Security.Common.dll" 
        Source="source\Origam.Security.Common.dll">
   </File>
</Component>

and a component reference to an existing “Architect” feature node:

<Feature Id="Architect" Level="1">
    <ComponentRef Id="ORIGAM.SECURITY.COMMON.DLL">
    </ComponentRef>
</Feature>

Great! And any hint how can I test the result? How to build msi installer and test weather it works?

I can add System.Numerics.Vectors but I can get into other errors, so I would like to test the scenario completely before I will commit changes.

Basically you have to install the wix toolset and have all the source files the setup requires in the source folder (as you can see in the example) and a zipped model in model_root_source\DefaultModel.zip file. A the moment we are using WIX version 3.11.

You can see the whole build procedure here. But basically it starts with copying the Architect build results to sources, compressing the model and running the wix commands candle and light.