Updating Origam Architect purges OrigamSettings file

OrigamSettings file is emptied, when updating Origam Architect 2021.1 to a new version.

I’d expect leaving OrigamSettings file intact.

Could not reproduce the issue. I tried:

  • uninstall ORIGAM Architect 2021.1
  • installed Architest 2021.1 from the latest OrigamSeup.msi

The typical user scenario is to install the new version without uninstalling the previous.

Ok. So I tried to:

  • uninstall the Architect
  • install Architect 2021.1 #2094
  • installing Architect 2021.1 #2096 over it

The OrigamSettings.config file did not change

I couldn’t reproduce the problem in 2021.1.0.2111. Closing the issue.

Maybe Architect Installer is missing version information - #8 by washi was causing this problem.

I’m not sure @jsusen couldn’t reproduce it with older builds as well.

I thought maybe the problem was that the setup might detect which files to replace by comparing the product version number. But it is not clear to me if it is so. This is how they say it works.

Also we set the KeyPath property to the file so that should result in not replacing the file ever if it exists.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.