Upgrade node from 12 to 14

Build of branch 2022.3 started failing. The error preventing the build was approximatelly this “package except@29.1.2 is not compatible with node 12”.

We do not depend on the package but some of our depencies do. You will find this looking at the yarn.lock:

  version "29.1.1"
  resolved "https://registry.yarnpkg.com/@types/jest/-/jest-29.1.1.tgz#cf21a..."
  integrity sha512-U9Ey...
    expect "^29.0.0"
    pretty-format "^29.0.0"

So someting depends on package @types/jest in ANY version and the currently installed version (29.1.1) depends on package expect version 29.0.0 or any higher minor or build version.
See documentation here:

You can see here that the version 29.1.2 of the expect package was released a week ago:

and version 29.1.1 of @types/jest was released at about the same time:

I only experienced the problem today probably because I deleted the directory node_packages so when I run yarn after that the latest versions were downloaded.

This problem might be in other branches as well.

Welcome to javascript development.