Windows SSO keeps asking for credentials

I’ve enabled Windows Auth with Negotiate and NTLM Providers. I Created record from BusinessPartner to OrigamUser. The UserName is in DOMAIN\username format. The Windows button appeared on login screen, but when I click the button, Windows login dialog is shown and you have to enter your AD login and password. Any suggestion how to omit Windows login dialog? I tried different providers, different username format but without success.

1 Like

One amendment - when I click Cancel on Windows login dialog an error page appears. Then I click back button in the browser and I can see Origam login page with one difference - there is information about currently logged windows user in the left upper corner of the page - attached image. So it looks user is authenticated but not allowed to enter the origam. Testing on 2021.2.0.2082.


The single sign on (SSO) functionality varies with browsers. What browser are you using? Also try to add the application’s URL to the trusted sites. That might help.

This seems to be a nice source of information for troubleshooting this issue:

I already tested those suggestions on Edge and Firefox but the issue persist :frowning_face: Is it necessary to set anything in appsettings.json or OrigamSettings.config?

No other settings needed on our side. I saw it working on a company network so it must be an issue between the browser and the server.

What about this?

I’ve just restored HTML5 Master version from backup an it works well. But it is not working in 2021.2.0.2082. Didn’t you change something in the code regarding IdentityServer?

Header from working master

header from not working master 2021.2.0.2082

I see. We were updating to IdentityServer4. This is the commit:

We will investigate further.

Seems the problem lays somewhere here:

This fix resolved the issue. It is now working as expected.
Thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.